[Linux] จะใช้ console ผ่าน com1 กับ linux

อยากทำเท่ config linux ผ่าน console เหมือนพวก router
vi /etc/grub.conf
serial –unit=0 –speed=9600
terminal –timeout=15 console serial

บรรทัด kernel ต่อท้ายบรรทัดด้วย console=tty0 console=ttyS0

ถ้า loader ใช้ lilo
vi /etc/lilo.conf
serial = 0,9600n8
append = “console=ttyS0,9600n8”

vi /etc/inittab
S1:12345:respawn:/sbin/agetty -L ttyS0 9600 vt100

vi /etc/securetty
! เอา remark ออกตรง ttyS0 เพื่อให้ root สามารถ login ได้

[Cisco] ใช้ Cisco ต่อ adsl modem แล้ว dial ออกไป

นานมาแล้วเรื่องมันมีอยู่ว่ามี router cisco อยู่ 1 ตัวถ้าไปซื้อ adsl module มันก็จะแพงไป พอดีเราก็มี adsl modem ที่ได้ฟรีมา ดีเลยเราใช้ cisco router ใช้ connect ผ่าน adsl modem ออกไป เยี่ยมเลยถ้าทำ nat ก็ work ไปเลย

PC— f0/1 { Cisco } f0/0 ——-(adsl modem)————-adsl line

conf t

ip dhcp pool default
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 203.144.y.y 203.144.x.x

interface f0/0
no ip address
no ip proxy-arp
pppoe enable group global
pppoe-client dial-pool-number 1

interface f0/1
ip add 192.168.10.1 255.255.255.0
ip tcp adjust-mss 1452
ip nat inside
no shut

no shutdown
interface dialer1
ip address negotiate
ip mtu 1492
encapsulation ppp
no ip proxy-arp
dialer pool 1
dialer-group 1
ppp chap hostname USERNAME
ppp chap password PASSWORD
ppp pap sent-username USERNAME password PASSWORD

ip nat inside source list 1 interface dialer1 overload
access-list 1 permit 192.168.10.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 dialer1
dialer-list 1 protocol ip permit

!————————————————————-

ลองเอาไปใช้ดูครับ

[Cisco] Config Cisco เป็น VPN/IPSec Server

ผมใช้ VPN Client ของ Cisco connect มาที่ Cisco7200 ip x.x.x.x เพื่อใช้ resource ที่อยู่ใน LAN
Group = CISCO_GROUP
Group Password = cisco_group
Username = cisco
Password = cisco

aaa authentication login vpn_authen local
aaa authorization network vpn_group_authen local
!
username cisco password cisco
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp client configuration group CISCO_GROUP
key cisco_group
pool VPN_CLIENT_POOL
acl 102
!
crypto ipsec transform-set vpn_client esp-3des esp-sha-hmac
crypto ipsec df-bit clear
!
crypto dynamic-map dynmap 50
set transform-set vpn_client
reverse-route
!
crypto map vpn client authentication list vpn_authen
crypto map vpn isakmp authorization list vpn_group_authen
crypto map vpn client configuration address respond
crypto map vpn 50 ipsec-isakmp dynamic dynmap
!
interface FastEthernet0/0
description ## LAN ##
ip address 172.31.1.254 255.255.255.0
duplex half

!
interface Serial0/0
description ## Internet ##
ip address x.x.x.x y.y.y.y
crypto map vpn
!
ip local pool VPN_CLIENT_POOL 172.31.3.1 172.31.3.10
!
access-list 102 permit ip 172.31.1.0 0.0.0.255 172.31.3.0 0.0.0.255
!

แสดงความคิดเห็นสำหรับ Blog ของผม

ช่วยแสดงความคิดเห็นหน่อยครับ อาจจะแนะนำว่าผมเขียนผิด หรือไม่ดีตรงไหนผมจะได้ปรับปรุงผลงานต่อไป ขอบคุณทุกคนที่เข้ามาเยี่ยมชมและแสดงความคิดเห็น หรือจะให้ผมช่วยอะไรได้บ้าง ก็บอกกันมา(ถ้าทำได้)……

[Cisco] เคยรำคาญกันบ้างไหมเวลาเราพิมพ์ command ผิดแล้ว???

เคยรำคาญกันบ้างไหมเวลาเราพิมพ์ command ผิดแล้วมันไป resolve dns หรืออื่นๆที่ทำให้เรารอนานกว่ามันจะขึ้น prompt

C3825-FTN-OFFICE#xxx !<--- แกล้ง router โดยใส่ command ผิดไป
Translating “xxx”…domain server (255.255.255.255) !<--- ไป resolve dns ทำให้รอนาน Translating “xxx”…domain server (255.255.255.255) Translating “xxx”…domain server (255.255.255.255)
(255.255.255.255)% Unknown command or computer name, or unable to find computer address
C3825-FTN-OFFICE#conf t
Enter configuration commands, one per line. End with CNTL/Z.
C3825-FTN-OFFICE(config)#no ip domain lookup !<--- disable ไม่ให้มันไป resolve dns
C3825-FTN-OFFICE(config)#exit
C3825-FTN-OFFICE#xxx !<--- อีกรอบลองใส่ผิดอีก
Translating “xxx” ! <--- มันดันไป translate อะไรอีกล่ะเนี่ย Translating “xxx” Translating “xxx”
% Unknown command or computer name, or unable to find computer address
C3825-FTN-OFFICE#conf t
Enter configuration commands, one per line. End with CNTL/Z.
C3825-FTN-OFFICE(config)#line vty 0 4
C3825-FTN-OFFICE(config-line)#transport preferred none !<---- นี้เลยไป disable มันซ่ะเลย
C3825-FTN-OFFICE(config-line)#
C3825-FTN-OFFICE#xxx
^
% Invalid input detected at ‘^’ marker. !<--- ค่อย make sense หน่อยว่าเราใส่ cmd ผิด C3825-FTN-OFFICE#

[Cisco] การ Ping test ระบุ options

การ ping test เราควรกำหนด pattern ของ data ที่ส่งออกไปเพื่อ test การตอบสนอง bit 0,1 ซึ่ง data ค่า default 0xABCD และถ้าต้องการกำหนด size ของ packet
– กำหนด pattern ของ DATA
#ping ip 192.168.1.1 data FFFF repeat 100
and
#ping ip 192.168.1.1 data 0000 repeat 100
– กำหนด size ของ packet แต่ถ้าเกิน MTU จะ ถูก defrag
#ping ip 192.168.1.1 repeat 100 size 2000
– กำหนด size ของ packet และ set DF bit (dont’ fragment bit)
#ping ip 192.18.1.1 repeat 100 size 2000 df-bit
– ระบุ source ip address
#ping ip 192.168.1.1 repeat 100 source 172.16.1.1
or
#ping ip 192.168.1.1 repeat 100 source Serial0/0 !– ระบุ source ip เป็นของ serial0/0

[Cisco] เขียน script tcl บน router

Cisco ก็สามารถเขียน script TCL ได้น่ะครับ ตัวอย่างต้องการ ping ไปหลายๆ ip

#tclsh ! เรียกใช้ tcl shell
foreach ip {
192.168.1.1
192.168.1.2
192.168.1.3
192.168.1.4
} { puts [ ping $ip source loopback0 repeat 100 ] }

! ก็จะเห็น Output
! ถ้าต้องการ ออกจาก tcl shell
#tclquit

เราสามารถเอาไป apply เพื่อใช้งาน script อื่นๆได้