Enable VRF multi-address-family on Cisco Catalyst 6500

#sh ver
Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(33)SXI2a, RELEASE SOFTWARE (fc2)

CAT6509(config)#ip vrf vrf1
CAT6509(config-vrf)#rd 1:1
CAT6509(config-vrf)#exit
CAT6509(config)#do sh vrf
Name Default RD Protocols Interfaces
vrf1 1:1 ipv4
CAT6509(config)#do sh run | sec ip vrf vrf1
ip vrf vrf1
rd 1:1
CAT6509(config)#ip vrf vrf1
CAT6509(config-vrf)#?
VPN Routing/Forwarding instance configuration commands:
bgp Commands pertaining to BGP
default Set a command to its defaults
description VRF specific description
exit Exit from VRF configuration mode
export VRF export
import VRF import
maximum Set a limit
mdt Backbone Multicast Distribution Tree
no Negate a command or set its defaults
rd Specify Route Distinguisher
route-target Specify Target VPN Extended Communities
snmp Modify snmp parameters
vpn Configure VPN ID as specified in rfc2685

CAT6509(config-vrf)#exit
CAT6509(config)#vrf def
CAT6509(config)#vrf definition vrf2
CAT6509(config-vrf)#rd 2:2
CAT6509(config-vrf)#address-family ipv4
CAT6509(config-vrf-af)#exit
CAT6509(config-vrf)#address-family ipv6
% VRF address family ipv6 is not supported or not enabled
% Can’t activate address-family ‘ipv6’
CAT6509(config-vrf)#exit
CAT6509(config)#mls ipv6 vrf
CAT6509(config)#vrf definition vrf2
CAT6509(config-vrf)#address-family ipv6
CAT6509(config-vrf-af)#exit
CAT6509(config-vrf)#exit
CAT6509(config)#do sh vrf
Name Default RD Protocols Interfaces
vrf1 1:1 ipv4
vrf2 2:2 ipv4,ipv6
CAT6509(config)#int lo100
CAT6509(config-if)#ip vrf forwarding vrf1
CAT6509(config-if)#int lo101
CAT6509(config-if)#vrf forwarding vrf2
CAT6509(config-if)#exit
CAT6509(config)#do sh vrf
Name Default RD Protocols Interfaces
vrf1 1:1 ipv4 Lo100
vrf2 2:2 ipv4,ipv6 Lo101
CAT6509(config)#do sh run int lo100
Building configuration…

Current configuration : 68 bytes
!
interface Loopback100
ip vrf forwarding vrf1
no ip address
end

CAT6509(config)#do sh run int lo101
Building configuration…

Current configuration : 65 bytes
!
interface Loopback101
vrf forwarding vrf2
no ip address
end

CAT6509(config)#vrf upgrade-cli multi-af-mode common-policies
You are about to upgrade to the multi-AF VRF syntax commands.

Are you sure ? [yes]:
Number of VRFs upgraded: 1
CAT6509(config)#do sh vrf
Name Default RD Protocols Interfaces
vrf1 1:1 ipv4 Lo100
vrf2 2:2 ipv4,ipv6 Lo101
CAT6509(config)#do sh run | sec vrf
mls ipv6 vrf
vrf definition vrf1
rd 1:1
!
address-family ipv4
exit-address-family
vrf definition vrf2
rd 2:2
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
vrf forwarding vrf1
vrf forwarding vrf2
CAT6509(config)#do sh run int lo100
Building configuration…

Current configuration : 65 bytes
!
interface Loopback100
vrf forwarding vrf1
no ip address
end

CAT6509(config)#do sh run int lo101
Building configuration…

Current configuration : 65 bytes
!
interface Loopback101
vrf forwarding vrf2
no ip address
end